Direct naar de inhoud
⚡ Kritieke cyberalerts voor jouw sector & systemen — direct in je inbox. Aanmelden →
cybernieuws.nl Cybersecurity en informatiebeveiling nieuws alerts live · 3 min 171 bronnen 2 kritiek 35 vandaag
CVE's Videos Dagbriefing

← Terug naar CVE-database

CVE-2026-33558

MEDIUM · 5.3 CVSS Gepubliceerd: CWE-533

Beschrijving NL

Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are:

* AlterConfigsRequest

* AlterUserScramCredentialsRequest

* ExpireDelegationTokenRequest

* IncrementalAlterConfigsRequest

* RenewDelegationTokenRequest

* SaslAuthenticateRequest

* createDelegationTokenResponse

* describeDelegationTokenResponse

* SaslAuthenticateResponse

This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

Origineel (Engels) tonen

Information exposure vulnerability has been identified in Apache Kafka.

The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are:

* AlterConfigsRequest

* AlterUserScramCredentialsRequest

* ExpireDelegationTokenRequest

* IncrementalAlterConfigsRequest

* RenewDelegationTokenRequest

* SaslAuthenticateRequest

* createDelegationTokenResponse

* describeDelegationTokenResponse

* SaslAuthenticateResponse

This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

Vendors

Apache

Affected products

Kafka

References