CVE-2026-110310
Beschrijving NL
Een externe gebruiker die gecodeerde objecten in de S3-bucket kan lezen, kan een padding-downgrade forceren door het padding-schema dat is vastgelegd in de metagegevens van een object te wijzigen in legacy PKCS#1 v1.5. Aangezien dit padding-schema vatbaar is voor de bekende Bleichenbacher-aanval, kan de gebruiker een PKCS#1 v1.5 padding oracle gebruiken om de met RSA verpakte envelope-sleutel te herstellen en het object te decoderen. Om dit probleem op te lossen, raden we gebruikers aan om te upgraden naar versie 3.2.2 of 4.0.3. De 1.x- en 2.x-lijnen worden niet gepatcht, gebruikers van die lijnen moeten migreren naar 3.2.2 of 4.0.3.
Origineel (Engels) tonen
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object.
To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.